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ВСТУП 

Навчально–методичні рекомендації складено відповідно до ОПП «Автома-

тика та автоматизація на транспорті» спеціальності 174 «Автоматизація, 

комп′ютерно-інтегровані технології та робототехніка»  та ОПП «Системи керу-

вання рухом поїздів» спеціальності 273 «Залізничний транспорт». Методичні 

рекомендації сприяють формуванню у студентам оволодіти важливими навич-

ками створення, редагування та оптимізації графічного контенту. Вони сприя-

ють формуванню розуміння принципів роботи графічних редакторів, техноло-

гій рендерингу, моделювання та створення векторної і растрової графіки. Особ-

ливу увагу приділено вивченню сучасних форматів файлів, кольорових моде-

лей, алгоритмів стиснення даних, а також основ дизайну і композиції.. 

Вимоги до попередніх знань та умінь: знати та вміти використовувати 

комп’ютер. 

Вимоги до програмних засобів: Microsoft 365. 

Використання технічних засобів: лабораторні роботи виконуються на 

комп’ютері, наданому університетом, або на комп’ютері здобувача освіти (Здо-

бувач). 

Якщо лабораторні заняття виконуються в спеціально призначеному примі-

щенні університету, то Здобувач зобов’язаний виконувати вимоги правил тех-

ніки безпеки та поводження у цьому приміщенні (доводяться до Здобувача пе-

ред початком/ на початку першого лабораторного заняття). 

Якщо лабораторні заняття виконуються на комп’ютері, наданому універси-

тетом, то: 

 Здобувачу заборонено змінювати налаштування програмної та технічної 

частини комп’ютера, окрім випадків, визначених цими методичними ре-

комендаціями. 

 У разі виникнення питань чи непередбаченої роботи обладнання – пові-

домити відповідальному працівнику університету (черговому по аудито-

рії, викладачу тощо). 

Вимоги до оформлення протоколу/звіту з лабораторного заняття (Звіт): 

 Звіт оформляється з використанням засобів комп’ютерної техніки та ро-

здруковується на аркушах формату А4 (шрифт основного тексту Times 

New Roman, шрифт тексту програм – моноширинний, розмір шрифту – 

мінімум 10 пт.). Допускається: оформлення власноруч та прикріплення 

додатків (рисунок, таблиця, текст програми тощо за потреби), які надру-

ковано за допомогою комп’ютерної техніки. 

 Звіт містить інформацію, яка ідентифікує його виконавця: прізвище та 

ім’я Здобувача, номер академічної групи, номер варіанту (якщо вимага-

ється в лабораторній роботі, то надається викладачам). 

 Наповнення Звіту відповідає розділу «Зміст звіту». 
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Порядок проведення лабораторного заняття: Здобувач виконує експеримен-

тальні дослідження відповідно до цих методичних рекомендацій, оформлює та 

захищає Звіт. 

Здобувач допускається до захисту Звіту, якщо наповнення Звіту відповідає 

вимогам у розділі «Зміст звіту». 

ВИЗНАЧЕННЯ НОМЕРА ВАРІАНТУ ЗАВДАННЯ 

Номер варіанту завдання позначається цілим числом і дорівнює сумі двох 

останніх цифр у шифрі Здобувача (номер індивідуального навчального плану), 

якщо не вказано іншого. Якщо чисельне значення номера варіанту завдання пе-

ревищує максимальне значення у множині номерів варіантів певного ЛЗ, то но-

мером варіанту вважати число, яке відображене на цю множину за принципом 

«mod N».  

Приклад: мінімальний номер варіанта в ЛЗ – один, максимальний номер – 

15. Якщо Здобувачу повідомлено номер варіанту 17 (або, наприклад, 32), то

прийняти за номер варіанту Здобувача значення 17–15=2 (або 32–2×15=2, від-

повідно). Якщо чисельне значення номера варіанту завдання менше за мініма-

льне значення у множині номерів варіантів певного ЛЗ, то номером варіанту 

вважати число, яке дорівнює мінімальному значенню множини номерів варіан-

тів ЛЗ. 

ВИМОГИ З ОХОРОНИ ПРАЦІ 

Загальні положення 

Якщо ЛЗ виконуються в спеціально призначеному приміщенні університе-

ту, то Здобувач зобов’язаний виконувати вимоги правил техніки безпеки та по-

водження у цьому приміщенні (повідомляються Здобувачу перед початком або 

на початку першого лабораторного заняття). 

Якщо ЛЗ виконуються на комп’ютері, наданому університетом, то: 

 Здобувачу заборонено змінювати налаштування програмної та технічної 

частини комп’ютера, окрім випадків, визначених цими НМР та вказів-

ками відповідального працівника університету (чергового по аудиторії, 

викладача тощо далі – Відповідальний). 

 У разі виникнення питань чи непередбаченої роботи обладнання Здобу-

вач зобов’язаний терміново повідомити Відповідальному. 

Обладнання робочого місця користувача комп’ютера (далі – Користувач): 

 Основне: монітор, клавіатура, робочий стіл, стілець (крісло);  
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 Допоміжне: підставка для ніг, шафи, полиці та інше. 

Взаємне розташування елементів робочого місця Користувача не повинно 

заважати виконанню необхідних рухів та переміщень для експлуатації 

комп’ютера; сприяти оптимальному режиму праці й відпочинку, зниженню 

втоми Користувача. 

Поверхню екрана монітора потрібно розташувати в оптимальній зоні інфо-

рмаційного поля в площині, перпендикулярній нормальній лінії погляду Корис-

тувача, який знаходиться в робочій позі. Допускається:  

 відхилення від цієї площини не більше 45°;  

 відхилення лінії погляду від нормального не більше 30°. 

Розташувати монітор на робочому місці необхідно так, щоб поверхня екра-

на знаходилась на відстані 500…600 мм від очей Користувача, залежно від роз-

міру екрана. 

Клавіатуру потрібно розташовувати на робочому столі (не допускаючи її 

хитання) або на окремому столі (якщо клавіатуру виконано як окремий при-

стрій) на відстані 100…300 мм від краю, що є ближчим до Користувача. Поло-

ження клавіатури та кут її нахилу (в межах 5…15°) повинен відповідати поба-

жанням Користувача. 

Крісло повинно забезпечувати підтримування раціональної робочої пози під 

час виконання основних операцій. Поверхня сидіння має бути плоскою, передні 

краї – закругленими. 

Раціональна поза Користувача: розташування тіла, при якому ступні Корис-

тувача розташовані на площині підлоги або на підставці для ніг, стегна зорієн-

товані у горизонтальній площині, верхні частини рук – вертикальні, кут ліктьо-

вого суглоба коливається у межах 70…90°, зап’ястя зігнуті під кутом не більше 

ніж 20°, нахил голови – у межах 15…20°, а також виключені часті її повороти. 

Вимоги безпеки перед початком заняття 

Оглянути робоче місце на відсутність сторонніх предметів. Якщо 

комп’ютер виконано у версії, якою передбачено під’єднання периферійного об-

ладнання за допомогою з’єднувальних шнурів (кабелів), то перевірити, чи все 

необхідне обладнання з’єднано відповідно. 

Перевірити надійність встановлення апаратури на робочому столі. Монітор 

повинен розміщуватись не на краю стола. Повернути монітор так, щоб було 

зручно дивитися на екран – під прямим кутом (а не збоку) і трохи зверху вниз; 

при цьому екран має бути трохи нахиленим – нижній його край ближче до Ко-

ристувача. 

Оглянути та перевірити загальний стан апаратури, справність електропро-

водки, з’єднувальних шнурів (кабелів), штепсельних вилок, розеток, заземлення 

захисного екрана. 

У разі виявленні будь-яких несправностей чи невідповідностей, роботу 

не розпочинати і повідомити про це Відповідальному. 
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Вимоги безпеки під час заняття 

Під час роботи на клавіатурі Користувач повинен сидіти прямо, 

не напружуватися. 

Заборонено:  

 самостійно ремонтувати та очищувати апаратуру на робочому місці; 

 перевищувати тривалість безперервної роботи за монітором, що складає 

2 години без регламентованої перерви. 

Вимоги безпеки після закінчення заняття 

У разі потреби зберегти файли, які є відкритими та перебувають в режимі 

редагування. Забрати з робочого місця особисті речі Користувача. 

Вимоги безпеки в аварійних ситуаціях  

У випадку раптового припинення постачання електроенергії вимкнути 

комп’ютер у такій послідовності: периферійні пристрої (у т.ч. монітор), проце-

сор, стабілізатор напруги (якщо є), витягнути штепсельні вилки з розеток. 

При виявленні ознак горіння (дим, запах гару): 

Вимкнути апаратуру, повідомити Відповідальному (у разі його відсутності 

знайти джерела займання і вжити заходів щодо ліквідації займання). 

Якщо немає можливості швидкого відключення електропроводів від джерел 

постачання, частину що горить, потрібно тушити тільки вуглекислотним вогне-

гасником або сухим піском. 

Якщо стався нещасний випадок, потрібно:  

 Надати потерпілому першу медичну допомогу. 

 Повідомити Відповідальному. 

 У разі потреби викликати «швидку допомогу». 

ПОЧАТКОВІ НАЛАШТУВАННЯ 

Якщо лабораторне заняття виконується на комп’ютері, наданому універси-

тетом, то для збереження результатів виконання лабораторного заняття (ЛЗ) 

створити каталог: 

Уточнити у викладача розташування на комп’ютері, призначене для збережен-

ня файлів Здобувачів, та перейти до цього розташування. 

Створити робочий каталог з іменем в форматі НомерГрупи_Прізвище, де 

НомерГрупи та Прізвище – номер групи та прізвище Здобувача відповідно. В 

подальшому результати всіх ЛЗ зберігати лише в даному робочому каталозі. 

Створити каталог з іменем в форматі ЛЗ_номер, де номер – номер поточного 

ЛЗ (наприклад, «ЛЗ_1»). 
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Перейти в каталог «ЛЗ_номер». В подальшому результати всіх поточних ЛЗ 

зберігати у відповідних каталогах. 

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 1  

ІНТЕРФЕЙС, НАЛАШТУВАННЯ ТА ОГЛЯД ІНСТРУМЕНТІВ 

ГРАФІЧНОГО РЕДАКТОРА GIMP 

Мета заняття: ознайомитися з інтерфейсом та основними можливостями 

графічного редактора GIMP. Навчитися виконувати базові налаштування про-

грами для зручності роботи. Отримати практичні навички використання основ-

них інструментів GIMP для редагування графіки.   

Короткі теоретичні відомості  

GIMP (GNU Image Manipulation Program) — це безкоштовний графічний редак-

тор із відкритим кодом, що використовується для редагування растрової графі-

ки, створення малюнків і фотомонтажу.   

Основні можливості GIMP:   

- Робота з шарами.   

- Інструменти виділення, малювання, ретуші, трансформації.   

- Робота з кольорами (градієнти, корекція кольору).   

- Підтримка різних форматів файлів (JPEG, PNG, TIFF, PSD тощо)[1; 4].   

Порядок виконання лабораторного зняття 

1. Ознайомлення з інтерфейсом GIMP

1.1. Запустіть програму GIMP.   

1.2. Розгляньте основні елементи інтерфейсу:  

 Меню: верхній рядок із командами для роботи з файлами, налаштуваннями 

та інструментами.   

 Панель інструментів: розташована зліва, містить базові інструменти (виді-

лення, пензлі, заливка тощо). 

 Робоча область: центральна частина для редагування зображень.   

 Панель шарів: справа відображаються всі шари поточного документа. 

 Інформаційна панель: відображає поточні параметри інструментів.   

1.3. Вивчіть функцію Одиночного вікна: 

 У меню виберіть Windows > Single-Window Mode, щоб увімкну-

ти/вимкнути цей режим. 

2. Налаштування GIMP для зручності роботи

2.1. Відкрийте меню Edit > Preferences:  

 Інтерфейс: змініть мову або тему оформлення.  
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 Інструменти: налаштуйте параметри за замовчуванням для пензлів, виді-

лень та інших інструментів. 

 Клавіатурні скорочення: у меню Interface > Configure Keyboard Shortcuts 

створіть або змініть сполучення клавіш для часто використовуваних функ-

цій.   

2.2. Перевірте функцію Autosave:  

 У меню Preferences > Input Devices > Save Input Device Settings on Exit уві-

мкніть автоматичне збереження.  

3. Огляд основних інструментів

3.1. Інструменти виділення:  

 Виділіть частину зображення за допомогою Rectangle Select або Ellipse 

Select. 

 Спробуйте Fuzzy Select для виділення областей за кольором. 

3.2. Інструменти малювання:   

 Використовуйте Brush Tool для малювання ліній.   

 Змініть розмір і форму пензля в панелі властивостей.   

 Спробуйте Bucket Fill Tool для заповнення області кольором або градієн-

том.   

3.3. Інструменти трансформації:  

 Спробуйте Move Tool для переміщення об’єктів.   

 Використовуйте Scale Tool для зміни розміру шару.   

 Виконайте обертання об'єкта за допомогою Rotate Tool. 

3.4. Робота з шарами: 

 Додайте новий шар у панелі Layers.   

 Налаштуйте прозорість шару за допомогою повзунка Opacity. 

4. Збереження та експорт файлів

4.1. Збережіть файл у форматі GIMP (.xcf) для подальшого редагування:  

 Меню File > Save As...   

4.2. Експортуйте зображення у формат PNG або JPEG для використання:  

 Меню File > Export As... 

Завдання для виконання: 

1. Завантажте будь-яке зображення та додайте до нього текст за допомогою ін-

струменту Text Tool.

2. Виконайте зміну кольору обраної області, використовуючи Fuzzy Select

Tool та Bucket Fill Tool.

3. Додайте на зображення новий шар і створіть на ньому декоративний еле-

мент.

Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання, з ві-



10 

дповідними поясненнями щодо їх змісту. 

3. Висновки.

Контрольні запитання 

1. Які основні елементи інтерфейсу GIMP ви можете назвати?

2. Як налаштувати режим одиночного вікна?

3. Для чого використовується панель шарів у GIMP?

4. Які інструменти виділення є в GIMP, і чим вони відрізняються?

5. Як експортувати зображення у формат PNG?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 2  

РОБОТА З ШАРАМИ У ГРАФІЧНОМУ РЕДАКТОРІ GIMP 

Мета заняття: ознайомитися з поняттям шарів та їх функціональністю у GIMP.  

Навчитися створювати, редагувати, переміщувати та налаштовувати шари. Ви-

вчити основні інструменти роботи з шарами для створення багатошарових зо-

бражень.   

Короткі теоретичні відомості  

Шари у GIMP — це окремі рівні, які працюють незалежно один від одного в 

межах одного зображення. Це дозволяє редагувати різні частини зображення, 

не впливаючи на інші[1; 4].   

Основні операції з шарами:  

 Створення шарів: для додавання окремих елементів у зображення.   

 Зміна порядку шарів: визначає, який шар відображається поверх інших.  

 Прозорість (Opacity) дозволяє змінювати рівень видимості шару.   

 Режими змішування (Blend Modes): задають, як шар взаємодіє з іншими. 

 Групи шарів: для зручної організації.   

Панель шарів:   

 Розташована праворуч (або в окремому вікні).   

  Містить список всіх шарів, їх атрибути та інструменти для роботи з ними. 

Порядок виконання лабораторного заняття 

1. Ознайомлення з панеллю шарів

1.1. Відкрийте програму GIMP і створіть новий файл:  

 Меню File > New. Виберіть розмір, наприклад, 800×600 пікселів. 

1.2. Відкрийте панель шарів:   

 Меню Windows > Dockable Dialogs > Layers. 

 Переконайтеся, що панель активна.   

2. Створення та редагування шарів
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2.1. Створення нового шару: 

 Меню Layer > New Layer... або кнопка New Layer у панелі шарів.  

 Вкажіть ім’я шару, наприклад, "Фон", виберіть заливку (білий, прозорий). 

2.2. Додавання зображень у шари:   

  Відкрийте зображення через File > Open as Layers. Воно з’явиться як но-

вий шар.   

2.3. Зміна порядку шарів: 

 У панелі шарів перетягніть шар вище або нижче інших. 

 Перевірте, як змінюється вигляд зображення.   

3. Робота з прозорістю та режимами змішування

3.1. Прозорість (Opacity): 

 Виберіть будь-який шар у панелі. 

 Змініть повзунок Opacity (100% → 0%) та спостерігайте, як шар стає про-

зорим.   

3.2. Режими змішування: 

 Застосуйте різні режими (наприклад, Multiply, Overlay) до шару через ви-

падаюче меню Mode у панелі шарів.   

 Спостерігайте, як шар взаємодіє з іншими.  

4. Інструменти редагування шарів

4.1. Переміщення шарів:  

 Використовуйте інструмент Move Tool для зміщення шару у робочій обла-

сті.   

4.2. Маска шару:  

 Додайте маску через Layer > Mask > Add Layer Mask. 

 Виберіть білий або чорний колір для показу чи приховування частин шару. 

4.3. Обрізання шарів:   

 Використовуйте інструмент Crop Tool для обтинання шару. 

5. Групування шарів

5.1. Створення групи шарів:  

 Меню Layer > New Layer Group. 

 Перемістіть кілька шарів у створену групу. 

5.2. Робота з групою:   

 Застосуйте одну операцію (переміщення, зміна розміру) до всієї групи. 

6. Завершення роботи

6.1. Збережіть файл у форматі GIMP (.xcf) для подальшого редагування.  

 Меню File > Save As...   

6.2. Експортуйте зображення у формат PNG або JPEG для використання.  

 Меню File > Export As... 

Завдання для виконання: 

1. Створіть новий файл і додайте три шари: фон, зображення, текст.

2. Застосуйте до текстового шару режим змішування Overlay.
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3. Додайте маску до шару із зображенням і зробіть частину зображення прозо-

рою.

4. Об’єднайте всі шари у групу.

Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.

Контрольні запитання 

1. Що таке шари та яку роль вони відіграють у GIMP?

2. Як змінити порядок шарів?

3. Як додати маску до шару та для чого вона використовується?

4. Як застосовуються режими змішування?

5. Як зберегти багатошарове зображення для подальшого редагування?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 3  

ІНТЕРФЕЙС, НАЛАШТУВАННЯ 

ТА ОГЛЯД ІНСТРУМЕНТІВ ГРАФІЧНОГО РЕДАКТОРА 

INKSCAPE   

Мета заняття: ознайомитися з інтерфейсом та базовими можливостями графі-

чного редактора Inkscape. Навчитися виконувати налаштування програми для 

зручності роботи.  Дослідити основні інструменти для створення та редагуван-

ня векторної графіки. 

Короткі теоретичні відомості  

Inkscape — це безкоштовний редактор для створення та редагування век-

торної графіки. Він використовується для створення ілюстрацій, логотипів, 

діаграм, графіків та інших елементів, які потребують масштабування без втрати 

якості.   

Особливості Inkscape:   

 Робота з векторними об’єктами (криві Безьє, багатокутники, текст).   

 Широкий набір інструментів для редагування.   

 Підтримка популярних форматів, таких як SVG, PDF, EPS, PNG[2; 4]. 

Порядок виконання лабораторного заняття 

1. Ознайомлення з інтерфейсом

1.1. Запустіть програму Inkscape. 
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1.2. Розгляньте основні елементи інтерфейсу:  

 Головне меню: містить всі команди програми. 

 Панель інструментів: розташована зліва і включає основні інструменти для 

малювання та редагування.  

 Робоча область: центральна частина, де створюються та редагуються 

об’єкти.  

 Панель властивостей: під робочою областю показуються параметри вибра-

ного інструменту. 

 Шари: меню праворуч для організації елементів на шарах. 

 Розмір полотна: відображає робочу область у межах заданого розміру (на-

приклад, аркуш А4).   

1.3. Виконайте налаштування робочого простору:  

  Перейдіть до меню File > Document Properties і налаштуйте розмір полот-

на, наприклад, 210×297 мм (формат А4). 

2. Налаштування програми для зручності роботи

2.1. Відкрийте Edit > Preferences для зміни налаштувань:  

 Interface (Інтерфейс): виберіть мову, тему (світлу чи темну) та розмір іко-

нок. 

 Tools (Інструменти): налаштуйте поведінку інструментів, таких як пензлі 

або лінії. 

 Autosave (Автозбереження): встановіть частоту автоматичного збереження 

проекту.   

2.2. Увімкніть допоміжні лінії:  

 У меню View > Guides увімкніть направляючі для точного розташування 

елементів.  

3. Огляд основних інструментів

3.1. Інструменти малювання: 

 Rectangle Tool: малювання прямокутників та квадратів.   

 Створіть прямокутник, натиснувши та перетягнувши мишу на робочій об-

ласті. 

 Ellipse Tool: малювання кіл та еліпсів.   

 Намалюйте коло, утримуючи клавішу Shift для збереження пропорцій. 

 Bezier Tool: створення кривих і ліній.   

 Використовуйте цей інструмент для малювання довільних форм.   

3.2. Інструменти редагування:  

 Select Tool: вибір та переміщення об’єктів.   

 Виберіть об’єкт і перетягніть його в інше місце.   

 Node Tool: редагування вузлів і контурів.   

 Виберіть об’єкт і перетягніть вузли для зміни його форми.   

 Transform (Обертання і масштабування):   У панелі Object > Transform змі-

ніть розмір, обертайте чи нахиляйте об’єкти.  

3.3. Робота з кольорами:   
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 Fill and Stroke (Заливка та обведення):   

 Виберіть об’єкт і задайте йому колір заливки через меню Object > Fill and 

Stroke. 

 Налаштуйте товщину та стиль обведення (суцільна, пунктирна лінія). 

3.4. Текст:  

 Використовуйте Text Tool для створення тексту.   

 Введіть текст, змініть його шрифт і розмір через панель властивостей. 

4. Збереження та експорт зображень

4.1. Збережіть файл у форматі SVG для подальшого редагування:  

  Меню File > Save As...   

4.2. Експортуйте зображення у формат PNG:  

 Меню File > Export PNG Image...  

 Налаштуйте роздільну здатність (наприклад, 300 dpi). 

Завдання для виконання: 

1. Намалюйте простий логотип, використовуючи прямокутники, еліпси та криві

Безьє.  

2. Додайте текст із назвою вашого логотипу.

3. Налаштуйте кольори заливки та обведення для кожного елемента логотипу.

4. Збережіть логотип у форматах SVG та PNG.

Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.

Контрольні запитання 

1. Які основні елементи інтерфейсу Inkscape ви можете назвати?

2. Як змінити розмір полотна?

3. Для чого використовуються інструменти Node Tool та Bezier Tool?

4. Як додати кольори заливки та обведення?

5. Як зберегти проєкт для подальшого редагування?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 4  

СТВОРЕННЯ ЛІНІЙНОЇ БЛОК-СХЕМИ ЗА ТЕХНІЧНИМ 

СТАНДАРТОМ. РОБОТА З ТЕКСТОМ У INKSCAPE 

Мета роботи: ознайомитися з інструментами для створення блок-схем у 

Inkscape. Навчитися додавати текст до блоків і оформлювати його відповідно 
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до технічного стандарту. Створити просту лінійну блок-схему, що відповідає 

технічним вимогам 

Короткі теоретичні відомості  

Блок-схема — це графічне зображення алгоритму чи процесу за допомогою 

блоків різних форм (рис. 4.1).   

Блоки мають стандартні форми:   

 Овал: початок/кінець.   

 Прямокутник: процес (дія).   

 Ромб: умова чи рішення.   

 Стрілки: зв’язки між блоками. 

Усі елементи блок-схеми мають містити текст, оформлений чітко і зро-

зуміло. 

Рис.4.1 Приклад основних блоків 

Основні вимоги до блок-схем:  

- Чітке дотримання стандартних форм блоків.   

- Текст повинен бути розташований усередині блоку.  

- Лінії зв’язків мають бути прямими або з кутами 90°.  

Порядок виконання лабораторного заняття 

1. Налаштування робочої області

1.1. Запустіть Inkscape.   

1.2. Налаштуйте розмір полотна:  

  Перейдіть до File > Document Properties. 
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    Виберіть формат, наприклад, А4 (210×297 мм).  

1.3. Увімкніть сітку для точного розташування блоків:  

    Меню View > Page Grid. 

    Налаштуйте щільність сітки у Edit > Preferences > Grids. 

2. Створення блоків блок-схеми

2.1. Овал (початок/кінець): 

  Виберіть інструмент Ellipse Tool (E). 

    Намалюйте овал (утримуйте Shift для збереження пропорцій). 

2.2. Прямокутник (процес): 

    Виберіть Rectangle Tool (R).  

    Намалюйте прямокутник потрібного розміру. 

2.3. Ромб (умова):  

    Використайте Rectangle Tool (R) для малювання ромба. 

    Поверніть форму на 45° за допомогою інструмента Rotate. 

3. З’єднання блоків стрілками

3.1. Виберіть Bezier Tool (B) для малювання ліній. 

3.2. Намалюйте стрілку між блоками.   

3.3. Задайте стрілку у властивостях:   

    Виберіть лінію.   

    У меню Stroke Style додайте маркер (Marker) на кінці лінії у вигляді стрі-

лки. 

4. Робота з текстом

4.1. Виберіть інструмент Text Tool (T). 

4.2. Додайте текст до кожного блоку:   

  Для початку/кінця: "Start" або "End".   

  Для процесу: опис дії, наприклад, "Введення даних".   

  Для умови: питання чи перевірка, наприклад, "X > 0?".  

4.3. Налаштуйте текст:  

    Шрифт: Arial або Times New Roman. 

    Розмір: 12–14 pt.   

    Вирівнювання: по центру блоку. 

4.4. Згрупуйте текст із відповідним блоком для зручності переміщення:  

 Виділіть блок і текст, натисніть Ctrl+G. 

5. Оформлення блок-схеми

5.1. Налаштуйте кольори блоків:  

    Заповнення: використовуйте світлі кольори (наприклад, світло-

блакитний). 

   Обведення: чорне, товщина лінії 1.5 px.   

5.2. Перевірте правильність розташування блоків і стрілок. 

5.3. Додайте заголовок схеми за допомогою Text Tool.   

6. Збереження роботи

6.1. Збережіть файл у форматі SVG для подальшого редагування:  



17 

    Меню File > Save As....   

6.2. Експортуйте блок-схему у формат PNG для використання у звітах:  

     Меню File > Export PNG Image....  

Завдання для виконання: 

1. Створіть блок-схему алгоритму перевірки числа на парність.

  Початок.   

    Введення числа.   

    Перевірка умови (X % 2 == 0).  

    Якщо так, вивести "Парне".   

    Якщо ні, вивести "Непарне".   

    Кінець.   

2. Додайте текст до всіх блоків та з’єднайте їх стрілками.

3. Оформіть блоки у різних кольорах.

Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.

Контрольні запитання 

1. Які стандартні форми використовуються у блок-схемах?

2. Як додати текст до блоку у Inkscape?

3. Які вимоги до розташування тексту в блоках?

4. Як налаштувати стрілки у з’єднувальних лініях?

5. Чому важливо зберігати файл у форматі SVG?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 5  

СТВОРЕННЯ БЛОК-СХЕМИ З РОЗГАЛУЖЕННЯМ ТА 

ЦИКЛАМИ У ГРАФІЧНОМУ РЕДАКТОРІ INKSCAPE 

Мета заняття: створення блок-схеми з розгалуженням та циклами у графі-

чному редакторі Inkscape. 

Короткі теоретичні відомості  

Розгалуження – це структурний елемент алгоритму або програми, який перед-

бачає виконання різних дій залежно від виконання певної умови. Це дозволяє 

створювати логічні перевірки та керувати потоком виконання програми. Види 

розгалужень: 
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 Повне розгалуження. Передбачає перевірку умови та виконання одного з 

двох можливих наборів команд. 

 Неповне розгалуження. Виконує певний блок коду лише у разі виконання 

умови. 

 Багатоваріантне розгалуження. Використовується для перевірки кількох 

умов. 

Розгалуження, приклад реалізації наведено на рисунку 5.1: 

 Використовується для перевірки умов (наприклад, "Якщо Х > 0").   

 Результат умови може бути True (Так) або False (Ні), що визначає напря-

мок подальшого виконання алгоритму. 

Рис. 5.1 Приклад реалізації розгалуження 

Цикл – це конструкція в програмуванні, яка дозволяє повторювати певний на-

бір команд до виконання певної умови. Це зменшує кількість коду та робить 

програму ефективнішою. Цикли поділяються на: 

 Цикли з передумовою. 

 Цикли з післяумовою. 

 Цикли з лічильником. 

Цикли, приклад реалізації наведено на рисунку 5.2: 

 Повторення дій доти, поки виконується умова.   

 Типовий приклад: "Для кожного значення i від 1 до 10". 

Рис 5.2 Приклад реалізації циклу 

Порядок виконання лабораторного заняття 

1. Налаштування робочої області
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1.1. Відкрийте Inkscape.   

1.2. Налаштуйте розмір полотна:  

 Меню File > Document Properties. 

 Виберіть формат А4 (210×297 мм).   

1.3. Увімкніть сітку для точного розташування блоків:  

 Меню View > Page Grid.   

 За потреби налаштуйте сітку у Edit > Preferences > Grids. 

2. Створення блоків блок-схеми

2.1. Початок та кінець: 

 Виберіть Ellipse Tool (E) для створення овалів.  

 Додайте текст "Start" у перший блок і "End" у останній блок за допомогою 

Text Tool (T). 

2.2. Процеси: 

 Виберіть Rectangle Tool (R) для створення прямокутників. 

 Додайте текст до кожного прямокутника (наприклад, "Введення значен-

ня").   

2.3. Умови (розгалуження): 

 Використовуйте Rectangle Tool (R) для створення ромба.  

 Обертайте прямокутник на 45° за допомогою Rotate Tool.  

 Впишіть текст умови, наприклад, "X > 0?".   

4. Стрілки:

 Виберіть Bezier Tool (B) для малювання стрілок між блоками. 

 Задайте стрілку у властивостях лінії:   

 Виділіть стрілку.   

 У меню Stroke Style задайте маркер у вигляді стрілки.   

3. Реалізація розгалуження та циклу

Розгалуження:  

 З’єднайте ромб (умова) з двома напрямками:   

 Стрілка з написом "Yes" веде до блоку, що виконується, якщо умова істин-

на. 

 Стрілка з написом "No" веде до іншого блоку. 

Цикл:   

 Створіть стрілку, що повертає потік до попереднього блоку.   

 Наприклад, після виконання дії додайте стрілку, яка повертає до умови в 

ромбі.   

 Додайте текст до стрілок, щоб позначити цикл (наприклад, "Повторити").  

4. Оформлення блок-схеми

4.1. Налаштуйте кольори:  

 Заповнення: овал — зелений, ромб — жовтий, прямокутник — блакитний. 

 Обведення: чорне, товщина лінії 1.5 px.   

4.2. Додайте заголовок схеми (наприклад, "Алгоритм із розгалуженням та цик-

лом") у верхній частині полотна.   
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5. Збереження роботи

5.1. Збережіть файл у форматі SVG для подальшого редагування:  

 Меню File > Save As....  

5.2. Експортуйте блок-схему у формат PNG для використання у звітах:  

 Меню File > Export PNG Image....  

Завдання для виконання: 

1. Побудуйте блок-схему алгоритму перевірки числа на простоту:

 Початок.   

 Введення числа N.   

 Ініціалізація змінної i = 2.   

 Умова: "N % i == 0?".   

 Якщо так — вивести "Складене".   

 Якщо ні — інкрементувати i, перевірити "i < √N?". Якщо умова істинна, 

повторити цикл.   

 Якщо жоден дільник не знайдено, вивести "Просте".  

 Кінець.   

2. Використайте кольорове оформлення для кожного типу блоку.

Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.

Контрольні запитання 

1. Які стандартні фігури використовуються для блоків у розгалуженнях та ци-

клах?

2. Як з’єднати блоки з умови за допомогою стрілок?

3. Які кроки необхідно виконати для реалізації циклу в блок-схемі?

4. Чому важливо позначати стрілки текстом (наприклад, "Yes" або "No")?

5. Як зберегти файл у форматі PNG?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 6  

ІНТЕРФЕЙС, НАЛАШТУВАННЯ ТА ОГЛЯД ІНСТРУМЕНТІВ 

ГРАФІЧНОГО РЕДАКТОРА AUTOCAD ONLINE  

Мета зняття: ознайомитися з інтерфейсом та функціоналом графічного ре-

дактора AutoCAD Online. Навчитися виконувати базові налаштування робочого 



21 

простору. Оглянути основні інструменти для створення та редагування крес-

лень. 

Короткі теоретичні відомості  

AutoCAD Online — це хмарний сервіс, який дозволяє працювати з крес-

леннями без потреби встановлювати програму на комп'ютер. Він підтримує ос-

новні функції для створення, редагування та перегляду DWG-файлів[3; 4]. 

Основні переваги AutoCAD Online: 

 Доступність з будь-якого пристрою. 

 Інтуїтивний інтерфейс, подібний до класичного AutoCAD. 

 Інтеграція з хмарними сховищами, такими як Google Drive, OneDrive та 

Dropbox. 

Порядок виконання лабораторного заняття 

1. Ознайомлення з інтерфейсом AutoCAD Online

1.1. Запуск графічного редактора: 

 Відкрийте [офіційний сайт AutoCAD Online](https://web.autocad.com). 

 Увійдіть у свій обліковий запис Autodesk. 

1.2. Огляд основних елементів інтерфейсу: 

 Робоча область: головне вікно для створення та редагування креслення. 

 Головне меню: доступ до команд, налаштувань, і довідкової інформації. 

 Панель інструментів: включає команди для малювання, редагування та 

управління шарами. 

 Командний рядок: введення команд вручну. 

  Навігаційні інструменти: кнопки масштабування, панорамування та обер-

тання креслення. 

2. Налаштування робочого простору.

2.1. Зміна одиниць вимірювання: 

 У командному рядку введіть `UNITS` і натисніть Enter. 

 У діалоговому вікні виберіть потрібні одиниці (міліметри, дюйми тощо). 

2.2. Налаштування сітки: 

 Увімкніть/вимкніть сітку за допомогою кнопки Grid на нижній панелі. 

  Налаштуйте розмір і вигляд сітки в меню Settings. 

2.3. Збереження налаштувань: 

 Використовуйте хмарні сховища для автоматичного збереження креслень і 

конфігурацій. 

3. Використання основних інструментів

3.1. Створення креслення: 

 Лінія (Line): Виберіть інструмент Line у панелі інструментів або введіть 

команду `LINE`. 

 Коло (Circle): Натисніть Circle та вкажіть центр і радіус. 
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 Прямокутник (Rectangle): Використовуйте команду RECTANGLE для 

створення прямокутних форм. 

3.2. Редагування об'єктів: 

 Переміщення (Move): Виділіть об'єкт, виберіть Move і вкажіть нове поло-

ження. 

 Копіювання (Copy): Використовуйте Copy для створення копій об'єкта. 

 Обрізання (Trim): Введіть `TRIM` для видалення частин об'єкта. 

3.3. Робота з шарами: 

 Створіть новий шар у вкладці Layers. 

 Призначте об'єктам різні шари для організації креслення. 

Завдання для виконання: 

1. Створіть просте креслення, що складається з прямокутника, кола та ліній.

2. Застосуйте інструменти редагування для зміни розташування та форми

об'єктів. 

3. Розробити креслення стандартного штампу для формату А4 (297×210 мм)

згідно з вимогами до оформлення технічної документації (рис. 6.1). Основний 

напис розташовують у правому нижньому куті формату. Його форма і зміст для 

креслень визначені Державним стандартом[5]. 

Рис.6.1 Стандартний штамп для формату А4 

3. Збережіть креслення у своєму хмарному сховищі.

Зміст звіту 

1. Номер, тема, мета ЛЗ.
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2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.

Контрольні запитання 

1. Які основні елементи інтерфейсу AutoCAD Online ви можете назвати?

2. Як змінити одиниці вимірювання в AutoCAD Online?

3. Для чого використовуються шари у кресленнях?

4. Які інструменти редагування об'єктів доступні у AutoCAD Online?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 7  

ПОБУДОВА СКЛАДНОЇ ДВОМІРНОЇ 

ФІГУРИ ІЗ З ВИКОРИСТАННЯМ ШАРІВ AUTOCAD ONLINE 

Мета роботи: ознайомитися з принципами створення складних двовимірних 

фігур у AutoCAD Online. Навчитися використовувати шари для організації 

креслень. Виконати побудову фігури з базовими розмірами та розподілити її 

елементи по шарах. 

Короткі теоретичні відомості  

Шари у AutoCAD Online використовуються для впорядкування креслень. Ко-

жен шар може мати свій колір, тип ліній, товщину, що дозволяє зручно управ-

ляти елементами креслення[3; 4]. Це особливо корисно при роботі з багатоком-

понентними об'єктами. 

Складна двовимірна фігура може включати: 

 Прямокутники. 

 Кола. 

 Лінії. 

 Дуги. 

Основні команди для побудови: 

 LINE (Лінія): створення відрізків. 

 CIRCLE (Коло): побудова кругів. 

 RECTANGLE (Прямокутник): створення прямокутників. 

 ARC (Дуга): побудова дуг. 

 DIM (Розмір): нанесення розмірів. 

Порядок виконання лабораторного заняття 

1. Підготовка робочого простору

1.1. Відкрийте [AutoCAD Online](https://web.autocad.com) та увійдіть у свій об-

ліковий запис. 
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1.2. Створіть новий проект. 

1.3. Налаштуйте одиниці вимірювання: 

 Введіть команду UNITS в командному рядку. 

 Виберіть метричну систему (міліметри) або іншу потрібну. 

2. Створення шарів

2.1. Відкрийте панель шарів (Layers). 

2.2. Створіть наступні шари: 

 Contour (Контур): основні геометричні фігури (колір червоний). 

 Dimensions (Розміри): для розмірних ліній (колір синій). 

 Auxiliary (Допоміжні): допоміжні лінії (колір зелений). 

2.3. Задайте для кожного шару відповідний колір, товщину та тип ліній. 

3. Побудова складної фігури

3.1. Контур фігури: 

 Активуйте шар Contour. 

 Побудуйте прямокутник розмірами 100×50 мм за допомогою команди 

RECTANGLE. 

 Додайте коло діаметром 30 мм у центрі прямокутника (CIRCLE). 

 Побудуйте дугу радіусом 20 мм у верхній частині прямокутника (ARC). 

3.2. Допоміжні лінії: 

 Перейдіть на шар Auxiliary. 

 Додайте діагональні лінії у прямокутнику (LINE) для позначення центрів і 

симетрії. 

3.3. Нанесення розмірів: 

 Перейдіть на шар Dimensions. 

 Використовуйте команду DIM для нанесення розмірів: 

 Довжина та ширина прямокутника. 

 Діаметр кола. 

 Радіус дуги. 

4. Оформлення креслення

4.1. Перевірте, чи всі елементи розташовані на відповідних шарах. 

4.2. Збережіть креслення у хмарному сховищі (Google Drive, OneDrive, або 

Autodesk Drive). 

Завдання для виконання: 

1. Побудуйте складну фігуру з індивідуальними параметрами, додавши інші

геометричні елементи (наприклад, еліпс). 

2. Додайте більше шарів для додаткових елементів і застосуйте різні типи ліній.

3. Використовуючі новий шар, нанесіть розміри на креслення великої рамки для

формату А4(допрацювати попередню лабораторну роботу). 

3. Експортуйте креслення у формат DWG.
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Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.

Контрольні питання: 

1. Як створити новий шар у AutoCAD Online?

2. Для чого використовуються шари у кресленнях?

3. Які інструменти потрібні для побудови дуги та нанесення розмірів?

4. Як перевірити, на якому шарі знаходиться об’єкт?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 8  

ПОБУДОВА СКЛАДНОЇ ДВОМІРНОЇ ФІГУРИ З 

ВИКОРИСТАННЯМ БЛОКІВ У AUTOCAD ONLINE 

Мета заняття: ознайомитися з принципами створення та використання блоків у 

AutoCAD Online.  Навчитися створювати блоки для спрощення роботи з багато-

разовими елементами креслення. Застосувати блоки для побудови складної 

двовимірної фігури. 

Короткі теоретичні відомості  

Блоки у AutoCAD  — це групи об’єктів, які об’єднані в єдину сутність. 

Вони дозволяють: економити час при створенні багаторазово використовуваних 

елементів, зберігати послідовність і точність креслення, легко редагувати всі 

екземпляри блоку через зміну його базового визначення[3; 4]. 

Основні команди роботи з блоками: 

 BLOCK (Блок): створення нового блоку. 

 INSERT (Вставка): вставлення існуючого блоку. 

 EXPLODE (Розрив): роз'єднання блоку на окремі елементи. 

Порядок виконання лабораторного занятя 

1. Підготовка робочого простору

1.1. Увійдіть у [AutoCAD Online](https://web.autocad.com) і створіть новий файл. 

1.2. Налаштуйте одиниці вимірювання: 

 Виконайте команду UNITS і виберіть метричну систему (наприклад, мілі-

метри). 

2. Створення основних геометричних елементів

2.1. Побудуйте базові елементи: 

 Прямокутник розміром 100×50 мм (RECTANGLE). 
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 Коло діаметром 30 мм (CIRCLE), розташоване всередині прямокутника. 

 Дві горизонтальні лінії, які ділять прямокутник на три рівні частини 

(LINE). 

2.2. Групуйте елементи за функціональністю: 

  Контур прямокутника і внутрішнє коло належать до основної фігури. 

  Горизонтальні лінії — це допоміжні елементи. 

3. Створення блоків

3.1. Виділіть всі елементи контуру прямокутника і внутрішнього кола. 

3.2. Виконайте команду BLOCK: 

 У діалоговому вікні задайте ім'я блоку, наприклад, BaseShape. 

 Виберіть точку вставки (нижній лівий кут прямокутника). 

 Натисніть OK. 

3.3. Для допоміжних горизонтальних ліній створіть окремий блок: 

 Виділіть лінії. 

 Виконайте команду BLOCK і задайте ім'я, наприклад, Guidelines. 

4. Використання блоків у кресленні

4.1. Вставте кілька копій блоку BaseShape: 

 Виконайте команду INSERT і виберіть блок BaseShape. 

 Розташуйте його у різних частинах креслення. 

4.2. Додайте блок Guidelines до кожного екземпляра BaseShape: 

 Вставте блок, використовуючи команду INSERT. 

 Вирівняйте його за точкою вставки блоку BaseShape. 

5. Редагування блоку

5.1. Внесіть зміни до блоку BaseShape: 

 Виконайте команду EDITBLOCK. 

 Додайте елемент, наприклад, нове коло. 

 Збережіть зміни. 

5.2. Перевірте, як зміни автоматично застосовуються до всіх екземплярів блоку. 

Завдання для виконання: 

1. Створіть двовимірну фігуру, яка складається з кількох блоків.

2. Додайте новий елемент до одного з блоків і перевірте, як це вплинуло на всі

його екземпляри. 

3. Використайте команду EXPLODE, щоб роз'єднати один з блоків на окремі

елементи. 

Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.
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Контрольні запитання 

1. Що таке блоки у AutoCAD і для чого вони використовуються?

2. Як створити новий блок у AutoCAD Online?

3. Як відредагувати існуючий блок?

4. У чому перевага використання блоків у складних кресленнях?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 9  

ПОБУДОВА ТРИВИМІРНОЇ ФІГУРИ У AUTOCAD ONLINE 

Мета заняття: Ознайомитися з інструментами для роботи з тривимірними 

об’єктами у AutoCAD Online. Навчитися створювати базові тривимірні геомет-

ричні фігури.  Використовувати інструменти для редагування та візуалізації 3D-

об’єктів. 

Короткі теоретичні відомості  

AutoCAD Online підтримує базові функції роботи з тривимірними моде-

лями, такі як створення, редагування та перегляд 3D-об’єктів[3; 4]. Основні 

операції з тривимірними фігурами включають:   

 Побудова 3D об’єктів: базових форм (кубів, циліндрів, сфер, конусів).   

 Модифікація: масштабування, обертання, об’єднання або видалення час-

тин.   

 Візуалізація: перемикання між 2D та 3D режимами перегляду. 

Основні інструменти:   

 BOX (Куб): створює тривимірний куб чи паралелепіпед.   

 CYLINDER (Циліндр): створює об’єкт із круглою основою.   

 SPHERE (Сфера): генерує тривимірну кулю.   

 EXTRUDE (Витягування): перетворює 2D-контур у 3D-об’єкт.   

 VIEWCUBE (Огляд): змінює перспективу для перегляду 3D-фігури. 

Порядок виконання лабораторного заняття 

1. Підготовка робочого простору

1.1. Увійдіть у [AutoCAD Online](https://web.autocad.com).   

1.2. Створіть новий файл і перевірте, чи активовано тривимірний простір. 

  Для цього у верхньому правому куті виберіть 3D Workspace. 

2. Побудова базових тривимірних фігур

2.1. Створення куба або паралелепіпеда: 

 Введіть команду BOX у командному рядку.   

 Вкажіть першу точку для основи куба.   

 Задайте розміри основи (довжина та ширина). 

 Вкажіть висоту куба.   
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2.2. Створення циліндра: 

 Введіть команду CYLINDER.   

 Вкажіть центр основи циліндра. 

 Задайте радіус основи.   

 Вкажіть висоту циліндра.   

2.3. Створення сфери: 

 Введіть команду SPHERE. 

 Вкажіть центр сфери.   

 Задайте радіус.   

3. Робота з інструментом витягування (EXTRUDE)

3.1. Намалюйте 2D-контур:  

 Використовуйте RECTANGLE для побудови прямокутника. 

3.2. Виконайте команду EXTRUDE:   

 Виберіть намальований прямокутник.   

 Задайте висоту витягування, щоб створити паралелепіпед. 

4. Налаштування перегляду

4.1. Використовуйте VIEWCUBE, щоб змінювати перспективу огляду. 

 Перемикайтесь між виглядами: зверху, знизу, збоку або ізометрія.  

4.2. Переключіть відображення об’єктів:   

 Виберіть Shaded для візуалізації з тінями.   

 Виберіть Wireframe для відображення каркасу. 

5. Редагування тривимірних фігур

5.1. Переміщення: Виконайте команду MOVE для зміщення об’єкта в просторі.   

5.2. Обертання: Використовуйте команду ROTATE3D для обертання об’єкта 

навколо осі.   

5.3. Об’єднання: Виконайте команду UNION для об’єднання двох об’єктів в 

один.   

5.4. Різання: Використовуйте команду SUBTRAC, щоб вирізати одну фігуру з 

іншої. 

Завдання для виконання: 

1. Побудуйте тривимірний об’єкт, що складається з куба, циліндра та сфери.

2. Виріжте сферу з куба за допомогою команди SUBTRACT.

3. Об’єднайте залишковий куб і циліндр за допомогою команди UNION.

Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.
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Контрольні запитання 

1. Які команди використовуються для побудови тривимірних фігур у

AutoCAD Online?

2. Як створити тривимірний об’єкт із двовимірного контуру?

3. Як змінити вигляд об’єкта за допомогою ViewCube?

4. Для чого використовуються команди UNION та SUBTRACT?

ЛАБОРАТОРНЕ ЗАНЯТТЯ № 10  

ПОБУДОВА СКЛАДНОЇ ТРИВИМІРНОЇ ДЕТАЛІ У AUTOCAD 

ONLINE 

Мета заняття: ознайомитися з інструментами для побудови тривимірних об'єктів 

у AutoCAD Online. Навчитися створювати складну тривимірну деталь з викори-

станням базових форм та операцій редагування.Закріпити навички роботи з ін-

струментами моделювання та перегляду 3D об'єктів. 

Короткі теоретичні відомості  

AutoCAD Online дозволяє створювати та редагувати тривимірні об'єкти, 

використовуючи базові геометричні форми (куб, циліндр, сфера тощо) та ін-

струменти для модифікації (витягування, об'єднання, різання)[3; 4].   

Основні команди:   

 BOX (Куб): створює тривимірний паралелепіпед.   

 CYLINDER (Циліндр): створює об’єкт із круглою основою.   

 SPHERE (Сфера): генерує тривимірну кулю.   

 EXTRUDE (Витягування): перетворює 2D-контур у 3D-об’єкт.   

 UNION (Об’єднання): поєднує кілька об'єктів в один.   

 SUBTRACT (Віднімання): вирізає одну фігуру з іншої.   

 INTERSECT (Перетин): створює об'єкт на основі перетину двох форм. 

Порядок виконання лабораторного заняття 

1. Підготовка робочого простору:

1.1. Відкрийте [AutoCAD Online](https://web.autocad.com).   

1.2. Створіть новий проєкт.   

1.3. Переконайтеся, що активовано тривимірний простір (3D Workspace). 

2. Побудова основних елементів деталі:

2.1. Створення основи деталі: 

 Використайте команду BOX для створення прямокутного паралелепіпеда з 

розмірами 100×50×20 мм.   

2.2. Додавання циліндричних елементів:  

 Виконайте команду CYLINDER.  
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 Задайте радіус 10 мм та висоту 50 мм. 

 Розташуйте циліндр на одному з кутів основи. 

2.3. Створення сферичного елемента: 

 Використайте команду SPHERE.   

 Задайте радіус сфери 15 мм.   

 Розташуйте сферу над центром основи. 

3. Застосування операцій модифікації:

3.1. Вирізання: 

 Виконайте команду SUBTRACT, щоб вирізати сферу з основи. 

 Виділіть основу як об'єкт, що залишиться, а сферу — як об'єкт для вида-

лення.   

3.2. Об’єднання: 

 Виконайте команду UNION для об’єднання циліндра з основою. 

3.3. Витягування:   

 Намалюйте 2D-контур прямокутника на основі.   

 Використайте команду EXTRUDE, щоб витягнути цей контур на висоту 10 

мм.  

4. Налаштування вигляду:

4.1. Використовуйте VIEWCUBE для зміни перспективи.   

4.2. Переключіть вигляд на Shaded, щоб краще бачити об’єкти у 3D.  

4.3. Перевірте точність з’єднання елементів у режимі Wireframe.   

5. Завершення та збереження роботи:

5.1. Перевірте деталь на відсутність зайвих елементів.   

5.2. Збережіть креслення у хмарному сховищі (Google Drive, OneDrive або 

Autodesk Drive).   

Завдання для виконання: 

1. Побудуйте складну тривимірну деталь, що включає кілька базових форм (куб,

циліндр, сфера) та операції вирізання та об’єднання.  

2. Додайте витягнуті елементи до своєї деталі.

3. Експортуйте модель у формат DWG для подальшого використання.

Зміст звіту 

1. Номер, тема, мета ЛЗ.

2. Скріншоти робочого аркуша, що ілюструють основні етапи виконання ро-

боти, з відповідними поясненнями щодо їх змісту.

3. Висновки.

Контрольні запитання 

1. Які команди використовуються для побудови основних 3D форм?

2. Як виконати об’єднання та вирізання об’єктів у AutoCAD Online?

3. Як змінити вигляд об’єкта за допомогою ViewCube?
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